Need help in installation error

Dear Lee....

I'm just installing SUAS MapServer 3i.21.1213 beta1 on my XAMPP server for local testing.....After uploading SHP files at first and then clicking continue I got error

Warning: domdocument::domdocument() expects parameter 2 to be long, string given in C:\xampp\htdocs\fesgis\Models\Installationi.class.php on line 621

Fatal error: Call to undefined method domdocument::createElement() in C:\xampp\htdocs\fesgis\Models\Installationi.class.php on line 634

My Environment is

Windows XP SP2
Apache/2.2.9 (Win32)
DAV/2
mod_ssl/2.2.9
OpenSSL/0.9.8h
mod_autoindex_color
PHP/5.2.6
mod_jk/1.2.26

Can you please help me in removing the error.

Regards....


Re: Need help in installation error

Keep on writing and chuggnig away!

Re: Need help in installation error

You're the geraetst! JMHO

Re: Need help in installation error

It's about time somoene wrote about this.

Re: Need help in installation error

Stay with this guys, you're helping a lot of poplee.

Re: Need help in installation error

can you give me the error message in detail?

Need help in installation error

Trying to install Suas Map server latest beta... however not able to complete step2 i.e 2.php..IMAGE verification code is not displayed to process for next step.
Kind regards
Amresh

Re: Need help in installation error

I was also trying to install SUAS mapserver3, using windows XP SP2. Just the same, it was unsuccessful.
------
vigilon

.

Re: Need help in installation error

try this:

http://www.easywms.com/easywms/?q=en/node/204#comment-4418

Re: Need help in installation error

Hi,

I have used latest version from google code and followed the instructions as per SUAS Mapserver tutorial and could not install using link http://localhost/suas/install/install.php .
Even i have tried using windows 7 but same problem. Please help me

Regards

Sri

Re: Need help in installation error

sridhar009 wrote:
I am using windows XP SP2 and trying to install suas mapserver3. But it was not sucussful and even tried suas mapserver4 (latest one) but same problem.
I have placed 'suas' folder in htdocs folder and followed the link http://localhost/suas/install/install.php and it showing an error message.
Please help me

regards

Sri

you got the same error here?have you downloaded the last version from google code?

Re: Need help in installation error

I am using windows XP SP2 and trying to install suas mapserver3. But it was not sucussful and even tried suas mapserver4 (latest one) but same problem.
I have placed 'suas' folder in htdocs folder and followed the link http://localhost/suas/install/install.php and it showing an error message.
Please help me

regards

Sri

its realy good

Thanks, for the good articles ...I am very intiresting..

Re: Need help in installation error

Its realy good,very helper thanks.

Re: Need help in installation error

I have met this problem long time ago, that is caused by some browsers can not recognize the header information sent from server, or server can not send the right Header because of some configuration, for example, the server send "image/PNG" in Header information when you are using getmap.php, but the browser does not know, it "thought" the data is one php file and will download it. But your php/mysql version is ok, i could not reproduce the error here. Could you just download the 'getmap.php' file and check what is inside? I guess there is some error messages, if not, please rename this file with png(or others you have requested) postfix, check whether it is one image or not.

Re: Need help in installation error

My system is windowsSP2,WEB Server is apache2.2.9, Mysql server is mysql5.0.22,php is 5.2.6.

Re: Need help in installation error

It sounds strange, which browser do you use? And what is your php and apache verison?

Re: Need help in installation error

I am using the SUAS MapServer 3i.21.1213 beta.
When I request the getcapabilities of WMS, I sometimes get a download page of "Would you download the getmapcap.php?" After several times try, I guess the bug revelent to database connection. But just a guess.

Re: Need help in installation error

Hi, which version are you using? The last version has fixed that bug.
and what is your error about "I cant parse getmapcap.php script"?

Re: Need help in installation error

My change is :

function databaseInsertGeometry($tablename, $layer, $recid, $geomtype, $xmin, $ymin, $xmax, $ymax, $geom, $svgxlink, $srs, $attributes, $style)
{
$fields = 'id,layer,recid,geomtype,xmin,ymin,xmax,ymax,geom,svgxlink,srs,attributes,style';
$values = "'NULL','" . $layer . "','" . $recid . "','" . $geomtype . "','" . $xmin . "','" . $ymin . "','" . $xmax . "','" . $ymax . "',GeomFromText('" . $geom . "'),'" . $svgxlink . "','" . $srs . "','" . $attributes . "','" . $style . "'";
$sql = "INSERT INTO " . $tablename . " (" . $fields . ") VALUES (" . $values . ")";
//echo $sql."\n";
$result = @mysql_query($sql, $this->databaseConnection);
if ($result) {
$this->recordgood ++;
}
if (!$result) {
//echo "Error:";
//echo $sql."";
$this->recordbad++;
$this->log .= "Error $this->recordbad :\n".$sql."\n";
$this->databaseErrorHandle("Error when insert records into database!");
}
}


After I change it, I can import shp data into database, other wise I got failed.

Re: Need help in installation error

Hi, sorry, i was in Nuremberg in the past 3 days.
id value should be null otherwise will get error when importing data into database. you have fixed the error? maybe it is caused by other reason. "I cant parse getmapcap.php script", i can catch up with you, what does this mean? Have you got any error code?

Re: Need help in installation error

dear lee:
when will you come? Please help me.

Re: Need help in installation error

I have fixed the error. But I find a new error. when I post getcapalities request, I cant parse getmapcap.php script. why?

Re: Need help in installation error

Error 1 :
INSERT INTO ssfeaturegeometry (id,layer,recid,geomtype,xmin,ymin,xmax,ymax,geom,svgxlink,srs,attributes,style) VALUES ('NULL','UK_rrline','UK_rrline_1','LineString','-4.4046998023987','54.32886505127','-4.3931307792664','54.332725524902',GeomFromText('MULTILINESTRING((-4.3931307792664 54.332019805908,-4.4023084640503 54.332725524902,-4.4043517112732 54.329990386963,-4.4046998023987 54.32886505127))'),'','SRS_not_defined','','Default')
the Error is Id field's value is null. but i can not find where to modify.

Re: Need help in installation error

please try to comment this extension as:
;extension=php_domxml.dll

Do NOT use it and restart apache.

Re: Need help in installation error

I'm also having the same problem.....is there any solution

deomurari wrote:
Dear Lee....

I'm just installing SUAS MapServer 3i.21.1213 beta1 on my XAMPP server for local testing.....After uploading SHP files at first and then clicking continue I got error

Warning: domdocument::domdocument() expects parameter 2 to be long, string given in C:\xampp\htdocs\fesgis\Models\Installationi.class.php on line 621

Fatal error: Call to undefined method domdocument::createElement() in C:\xampp\htdocs\fesgis\Models\Installationi.class.php on line 634

My Environment is

Windows XP SP2
Apache/2.2.9 (Win32)
DAV/2
mod_ssl/2.2.9
OpenSSL/0.9.8h
mod_autoindex_color
PHP/5.2.6
mod_jk/1.2.26

Can you please help me in removing the error.

Regards....

Re: Need help in installation error

Hi, forget my old answer, please try to comment this extension as:
;extension=php_domxml.dll
Do not use it and restart apache.

have a look at this:
http://bugs.php.net/bug.php?id=32743&edit=1
"Yes, the problem was with my php.ini whereby I was loading the
php_domxml.dll in the extensions. Once I removed that from the
extensions and restarted the web service all was good with instantiating
that DOMDocument() object."

Re: Need help in installation error

Hi there....

Thanks for the reply...
But I have DOMXML enabled in my setup.....

I have following extensions enabled...

extension=php_bz2.dll
extension=php_curl.dll
extension=php_dbase.dll
extension=php_domxml.dll
extension=php_gd2.dll
extension=php_gettext.dll
extension=php_imap.dll
extension=php_java.dll
extension=php_mbstring.dll
extension=php_exif.dll
extension=php_mcrypt.dll
extension=php_mime_magic.dll
extension=php_ming.dll
extension=php_mssql.dll
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_pdf.dll
extension=php_pdo.dll
extension=php_pdo_mssql.dll
extension=php_pdo_mysql.dll
extension=php_pgsql.dll
extension=php_phpdoc.dll
extension=php_soap.dll
extension=php_sockets.dll
extension=php_sqlite.dll
extension=php_stats.dll
extension=php_xmlrpc.dll
extension=php_xsl.dll
extension=php_zip.dll
extension=php_ps.dll
extension=php_paradox.dll

Hope this will help you in finding solutions.....Please let me know if any more information is needed...

Regards

Re: Need help in installation error

Hi, sorry for delay,this month is so busy.

C:\xampp\htdocs\fesgis\Models\Installationi.class.php on line 621:

$doc = new DOMDocument('1.0', 'utf-8');

Have you open the DOM XML Functions in PHP?
Windows users will enable php_domxml.dll inside of php.ini in order to use these functions.
Hope this will help you.